Keyboard shortcuts use wrong keys with Colemak, Dvorak, etc

iandunn's Avatar

iandunn

29 Apr, 2021 06:58 PM

Hi, thanks for Timeline, I love it and use it every day.

I recently switched to the Colemak keyboard layout, and noticed that keyboard shortcuts are still using the QWERTY keys. Steps to reproduce:

  1. set Toggle Timer shortcut to ctrl-alt-t
  2. type ctrl-alt-t, it will toggle the timer
  3. switch to Colemak (or Dvorak) - system preferences > keyboard > input sources
  4. type ctrl-alt-t (Colemak's t is where QWERTY places the f key), it won't toggle the timer
  5. type ctrl-alt-g (Colemak's g is where QWERTY places the t key), it will toggle the timer

I'm guessing the keycodes are hardcoded or something, rather than adapting to what the OS provides?

Thanks!
Ian

  1. Support Staff 1 Posted by Niko on 29 Apr, 2021 08:10 PM

    Niko's Avatar

    Hi Ian,

    I’m happy to hear that you are using Timelime every day!

    When you switch your keyboard layout to Colemak, the shortcut “position” on the keyboard will stay the same, like you described.
    I noticed that when you check the “Hotkeys” tab in Timelime’s preferences, the recorded key combination will update to the equivalent key in Colemak layout.

    Timelime is using third party code for defining and handling keyboard shortcuts. This one: https://github.com/Kentzo/ShortcutRecorder
    I have checked two other shortcut open source projects: https://github.com/shpakovski/MASShortcut and https://github.com/sindresorhus/KeyboardShortcuts.
    They both show the same behavior regarding the issue you are describing.

    I’ll have to check if this can be changed easily.

    Alternatively, if you use a different keyboard layout permanently, you can adjust the shortcuts in Timelime’s preferences.

    Thanks,
    Niko

  2. 2 Posted by iandunn on 29 Apr, 2021 08:57 PM

    iandunn's Avatar

    Ah, that worked, thanks!

    Other apps switched automatically, so I opened an issue upstream.

  3. iandunn closed this discussion on 29 Apr, 2021 08:58 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac