Sync gets disabled when being disconnected from the network

Markus's Avatar

Markus

22 May, 2018 06:18 PM

Hi,
great app! Love it.
One problem though: If the sync fails because the Mac is not connected to the network, It seems to permanently turn off syncing. Need to manually reenable it, merging the timings. This is pretty annoying. Is this a wanted behaviour?
Best regards,
Markus

  1. Support Staff 1 Posted by Niko on 26 May, 2018 06:17 AM

    Niko's Avatar

    Hi Markus,

    Sorry for the late reply and thank you for reporting this issue.
    This is definitely not wanted behavior and should not happen.

    When your Mac is not connected to the network, the sync status should say “Connected - No network, will sync when back online.” in Preferences > Sync. When your Mac is connected again, it should automatically sync and the status should change to “Connected - Last sync: …”.

    I am unable to reproduce the behavior you are describing, so I would need some more info:
    - what’s your version of macOS
    - what’s your version of Timelime
    - what sync method are you using (iCloud, Dropbox, or WebDAV)

    Thanks for your help,
    Niko

  2. 2 Posted by Markus on 28 May, 2018 01:11 PM

    Markus's Avatar

    Hi Niko,
    no problem. Here are more details:

    - Using Dropbox
    - Actually it's not a disconnect from the network but rather switching to a restricted network (in the office)
    - At the beginning it does retries: "Unable to sync, trying again in a few seconds"
    - In the end, it stops sync with this message: "Timeline disconnected from Dropbox. Error Description: An SSL error has occurred and a secure connection to the server cannot be made. | Domain: NSURLErrorDomain | Code: -1200"
    - Timelime version: 1.5.14
    - macOS version: 10.13.3

    Best regards and thanks for your help,
    Markus

  3. Support Staff 3 Posted by Niko on 30 May, 2018 10:17 AM

    Niko's Avatar

    Hi Markus,

    Thank you for the details, this helps a lot!
    However I am still unable to reproduce the issue.
    Can you describe you restricted network at the office further?
    To sync with Dropbox, Timelime needs to make an SSL connection (https) to “api.dropbox.com” on TCP port 443. I am guessing that for some reason your network doesn’t allow this.

    Thanks again,
    Niko

  4. 4 Posted by Markus on 15 Jun, 2018 12:07 PM

    Markus's Avatar

    Hi Niko,
    sorry for the late reply. Yes, Dropbox is generally blocked in this network.

    I managed to reproduce the issue by blocking access to Dropbox by Little Snitch, I guess blocking the port in the router should work as well.

    The key thing is to wait, I think it took like half an hour in the "Unable to sync, trying again in a few seconds" mode until I got the final message and sync switched off.

    Best regards,
    Markus

  5. Support Staff 5 Posted by Niko on 18 Jun, 2018 09:30 AM

    Niko's Avatar

    Hi Markus,

    Thanks for getting back to me.

    I tried to reproduce the issue like this:
    1. Little Snitch is configured so that it allows connections from Timelime app to “dropbox.com <http://dropbox.com/>” and “dropboxapi.com <http://dropboxapi.com/>”.
    2. Timelime is connected to Dropbox and and in sync (everything working fine).
    3. I disable the network connection by turning WiFi off.
    4. I edit the two rules in Little Snitch so that connections from Timelime app to “dropbox.com <http://dropbox.com/>” and “dropboxapi.com <http://dropboxapi.com/>” are now denied.
    5. I enable the network connection again by turning WiFi on.
    6. I start a timer of a task in Timelime to trigger synchronization.
    7. I go to Timelime > Preferences > Sync and see the message “Could not connect to the server. Trying again in a minute.”
    8. I close the Timelime Preferences Panel and wait two minutes.
    9. I go to Timelime > Preferences > Sync again and see the message “Connected - No network, will sync when back online.”
    10. Within the next hour I am starting and stopping a couple of timers, but all I ever see in the sync preferences are the tow messages mentioned above and the sync never disconnects completely.
    11. Now I turn the Wifi off again and edit the two rules in Little snitch to allow the connections to Dropbox.
    12. I turn Wifi on and Timelime automatically syncs properly. (In the sync preferences it says: “Connected - Last sync: …”

    -> So in my case it was working as expected.

    I am wondering why you got a different message ("Unable to sync, trying again in a few seconds”).
    Could you try again, and when this message appears, please open the Console app (Applications > Utilities > Console). There, enter “timelime” in the search field in the top right corner of the app window.
    Then you should see some error messages with info about what caused this state (“unable to sync…”).
    If you send me these log messages, I’ll can try to figure out what is happening.

    I’m pretty much ready to release an update to Timelime in the App Store, but I’d like to include a fix to your issue. So I’d be great if we get this figured out:)

    Thanks again,
    Niko

  6. 6 Posted by Markus on 18 Jun, 2018 10:55 AM

    Markus's Avatar

    Hi Niko,
    I will try and provide the console output.
    If you still have your setup running, you could quickly try to just filter out just"api.dropbox.com" or just "dropbox.com" (I had only one of those, but now I don't remember which one)
    Best regards,
    Markus

  7. 7 Posted by Markus on 18 Jun, 2018 12:37 PM

    Markus's Avatar

    This is very strange indeed. I get the same result when using your steps. I'll send you the logs by email.
    Best regards,
    Markus

  8. Support Staff 8 Posted by Niko on 18 Jun, 2018 03:37 PM

    Niko's Avatar

    Thanks for the logs!

    So when simulating with Little Snitch I get this error: Error Domain=NSURLErrorDomain Code=-1004 \"Could not connect to the server.\”
    In your network environment you get a different error: Error Domain=NSURLErrorDomain Code=-1200 "An SSL error has occurred and a secure connection to the server cannot be made.”

    I’ll try to figure out what causes your error and try to find a way to reproduce it. I’ll also check my code, what might cause the disconnect from sync.
    Will get back to you...

  9. Support Staff 9 Posted by Niko on 19 Jun, 2018 11:32 AM

    Niko's Avatar

    Hi Markus,

    I wasn’t able to reproduce the exact error you are getting. But I changed the code, so the Timelime sync will not disconnect anymore when this network error occurs. I hope this will fix it for you:)

    I’ll release the update soon…

    Niko

  10. 10 Posted by Markus on 19 Jun, 2018 02:51 PM

    Markus 's Avatar

    Sounds great! Thanks a lot
    Markus

  11. 11 Posted by Markus on 24 Jul, 2018 11:53 AM

    Markus's Avatar

    Hi Niko,
    just wanted to let you know that in the new version, everything works as desired. Thanks again!
    Markus

  12. Support Staff 12 Posted by Niko on 24 Jul, 2018 04:30 PM

    Niko's Avatar

    Cool, thanks for letting me know!

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

21 Sep, 2018 03:14 PM
13 Sep, 2018 09:26 AM
12 Sep, 2018 10:16 AM
05 Sep, 2018 06:04 AM
16 Aug, 2018 06:42 AM