CSV Export

Olaf's Avatar

Olaf

05 Jan, 2015 04:30 PM

The cvs export shows different sums of the included Hours only by changing the format in the "includes durations" area. If default value result is wrong, if the exported file is imported into Excel and the durations are summed up there, it shows the same result as the Timeline status line and not the wrong one of the export. Please see the 2 attached screenshots.

Regards,
Olaf

  1. Support Staff 1 Posted by Niko on 05 Jan, 2015 05:38 PM

    Niko's Avatar

    Hi Olaf,

    Thanks for reporting this!
    However, I'm unable to reproduce this issue. I also checked the code and the calculation of the total time should work as expected.

    Between taking these two screenshots, did you just change the setting for the duration format?
    Are you able to reproduce the problem? I'd be very interested in the steps that lead to this.
    Also are you using the latest version of Timelime (1.2.4)?

    Thanks,
    Niko

  2. 2 Posted by olaf.wuellenrat... on 05 Jan, 2015 06:22 PM

    olaf.wuellenrath's Avatar

    Ich habe vor einem Monat eine Migration auf einen anderen Rechner durchgeführt. Ich hab gerade noch einmal den alten Rechner eingeschaltet und auch dort kann ich das Problem für beliebige Zeiträume reproduzieren.

    Das heißt durch den Backup Export und den Reimport auf den neuen Rechner ist das Problem nicht entstanden, sondern es existierte schon vorher.

  3. 3 Posted by olaf.wuellenrat... on 05 Jan, 2015 06:29 PM

    olaf.wuellenrath's Avatar

    Hallo Niko,

    ich habe zwischen den beiden Screenshot wirklich nur das Format geändert und das Menü noch nicht einmal verlassen. Das geht auch so jeweils in die CSV Datei.

    Das ist reproduzierbar. Ich kann das auch gerne via Teamviewer zeigen.

    Gruß
    Olaf

  4. Support Staff 4 Posted by Niko on 05 Jan, 2015 06:52 PM

    Niko's Avatar

    Hi Olaf,

    ahhh, jetzt weiss ich woran das liegt.
    Um den Fehler zu umgehen, kannst du kurzzeitig unter "System Preferences" > "Language & Region" > "Advanced" > "Number Separators" den Punkt und das Komma austauschen (englisches Format).
    Dann geht es... :-)

    Ich werde den Bug in der nächsten Version beheben.
    Tausend Dank Dir für das Berichten. Mir wäre der Fehler wahrscheinlich nie aufgefallen.

    Liebe Grüsse,
    Niko

  5. 5 Posted by olaf.wuellenrat... on 05 Jan, 2015 07:59 PM

    olaf.wuellenrath's Avatar

    Hi Niko,

    Ich hab das auch nur per Zufall gefunden, wenn man weiß, dass das passiert kann, man es ja problemlos in Excel korrigieren oder einfach ein anderes Format nutzen ....

    Ich habe vorhin auch einen Verbesserungsvorschlag "Zeitbudget" eingegeben, wenn Du das für erwägenswert halten solltest und ich mich in engl. etwas unklar ausgedrückt haben sollte, einfach fragen.

    Gruß
    Olaf

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • CSV_export_error.png 103 KB
  • CSV_export_correct.png 118 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

27 Jan, 2023 11:56 AM
27 Jan, 2023 10:25 AM
23 Jan, 2023 04:48 PM
07 Jan, 2023 03:19 AM
16 Dec, 2022 11:29 AM