colors get clobbered

Andy's Avatar

Andy

23 May, 2014 05:59 PM

Often, when I set a task color, one of the other tasks (even a subtask of another group) also gets that color. I can write up the steps to recreate this from scratch if you want, but for now, I can say that I edit the color of a subtask of the one group, and then I have to double-check all of the others. Before, it seemed to be a glitch that I could clear up right then and there. However, I'm going in a circle chasing several of these clobbered colors over and over, and I can't get them all straight. They keep getting messed up.

  1. Support Staff 1 Posted by Niko on 23 May, 2014 06:10 PM

    Niko's Avatar

    Hi Andy,
    this sounds real messy and shouldn't happen. I'd be interested in how to recreate this bug.

    Thank you for reporting!
    Niko

  2. 2 Posted by Andy on 23 May, 2014 06:11 PM

    Andy's Avatar

    Yeah, pretty messy. :-/ Ok, I'll see if I can recreate this from an empty database.

  3. Support Staff 3 Posted by Niko on 23 May, 2014 06:13 PM

    Niko's Avatar

    Thanks!

  4. 4 Posted by Andy on 24 May, 2014 01:27 AM

    Andy's Avatar

    I wasn't able to recreate this from scratch, so I'm attaching a backup file that shows this behavior (I renamed everything in it). Most of the groups (except group 1) have subtasks with matching colors. For example, group2 should be all white (FFFFFF), group 4 should be all dark gray (333333), and group 5 should be all yellow-orange (FFCC00). Also, g3 group 1 (under group 3) should be all purple (7030B0). Whenever you try to correct a task that doesn't match its sibling tasks, certain tasks in the other groups I've mentioned will take on whatever color you select for that task. For example, in group 2, there may be a task that is not white. If you fix that task to be white so that it matches the other tasks in that group, then...a task will also turn white in both group 4 and group 5, as well as g3 group 1. The same tasks are getting their colors replaced by the color that was last selected. Try it and see if the same thing happens for you. The other groups/tasks seem to be ok.

  5. Support Staff 5 Posted by Niko on 26 May, 2014 12:12 PM

    Niko's Avatar

    I have tried to reproduce the issue you are describing using the provided XML file. However, everything works as expected here, so I can't troubleshoot this.

    What you can try is this (using the "Backup" tab in the app's preferences):
    1. Backup your entire database
    2. Clear your database
    3. Restore all of your data.

    Does this fix the problem?

  6. 6 Posted by Andy on 26 May, 2014 06:12 PM

    Andy's Avatar

    Very weird. Those steps per se did not solve the problem. However, I ended up doing more experiments, such as moving the affected tasks into a group and deleting everything else to whittle it down to a smaller database with the same glitches.

    It stopped responding while I was deleting things. I couldn't interact with anything except that the Preferences window still worked (since I still had it open) and right-clicking the menubar status still worked (but not left-clicking). I had to close and restart it.

    But guess what. Now it works fine.

    I don't know...I was convinced that it was a data issue, but I guess it wasn't! I had closed and restarted it before, and I had rebooted for system updates, but neither had seemed to stop the glitches. I wonder if deleting tasks cleaned something up, outside of the database. I had started out deleting tasks one by one, but then I accidentally deleted an entire group at once, and that's when it locked up. There was no beachball, but I remember there was a "busy" sort of (animated?) icon in the main window itself somewhere in the bottom bar, maybe under the calendar.

    So, I hope the colors behave from now on. I'll be watching that for a while.

  7. 7 Posted by Andy on 26 May, 2014 10:55 PM

    Andy's Avatar

    Well, the color-clobbering came back...after the delay/beachball thingie. I think there's some memory corruption going on here--that's the only explanation I can think of. Besides, after closing Firefox to free up memory and restarting Timelime, I was able to fix up the colors and that worked fine.

    So I guess it's back to the delay/beachball problem that we're having. Other than adding more memory (which I can't do right now) I hope there's some way to make Timelime more stable for me.

  8. 8 Posted by Irina on 14 Jan, 2015 05:49 AM

    Irina's Avatar

    Hi, I had the same issue with colors: random pairs of tasks sometime get synchronized color - when I change color on one of them, other gets the same. However, tasks are not related to each other (does not have task - subtask relation).
    App restart seems to fix the problem, but I did not do extensive testing yet.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

01 Feb, 2023 08:14 AM
31 Jan, 2023 11:11 AM
27 Jan, 2023 11:56 AM
27 Jan, 2023 10:25 AM
23 Jan, 2023 04:48 PM